Vivek Agarwal’s Portal/Java Blog

An IBM Gold Consultant’s weblog about IBM, Lotus, WebSphere, J2EE, IT Processes, and other IT technologies

Posts Tagged ‘WebSphere Portal v6’

How do you change the LDAP server name for a WebSphere Portal v6 server?

Posted by Vivek Agarwal on June 18, 2008

Today one of the portal administrators in my team was trying to reconfigure the LDAP server being used by an existing WebSphere Portal v6 install. The specific reconfiguration that he was doing was extremely simple – he was replacing one LDAP server with another identically configured LDAP server – so the only change was the name of the LDAP server. We were able to perform this change without disabling/re-enabling security in WebSphere Portal. Read the rest of this entry »

Posted in Java, Portal, WebSphere, WebSpherePortal | Tagged: , , , , , | 8 Comments »

WebSphere Portal v6 Global Deployment – Content Sync

Posted by Vivek Agarwal on November 20, 2007

Here is a quick update on content synchronization between 2 sites in a multi-master global deployment scenario. I had written sometime back about using JCR schema replication to ensure that WCM and PDM content synchronize between the two sites. This had initially seemed to work well during our mirror testing, but issues cropped up later. Read the rest of this entry »

Posted in Java, WebSpherePortal | Tagged: , , , | 4 Comments »

XA Errors on server startup after an ungraceful shutdown of WebSphere Portal v6

Posted by Vivek Agarwal on November 14, 2007

There is a new technote out about an issue that I have seen in the past with WebSphere Portal v6 on a test server, where you find XA errors in SystemOut.log during server startup after WP6 was shutdown ungracefully – for example, on a Windows server reboot after installing a Windows update. Resolving the error was relatively straightforward and involved clearing the transaction logs. Read the rest of this entry »

Posted in WebSphere, WebSpherePortal | Tagged: , , | Comments Off on XA Errors on server startup after an ungraceful shutdown of WebSphere Portal v6

How to enable “synchronous portlet edits” in a WebSphere Portal 6.0 cluster?

Posted by Vivek Agarwal on November 13, 2007

My blogs are getting more and more infrequent recently – things have been more crazy lately at work and I have also been reading a few non-technical books, leaving me less time to write on my blog. Today – I decided to prioritize blogging over other things and write about an issue that had plagued a WebSphere Portal v6.0 cluster. Essentially, if you create a WP6 cluster following the instructions from IBM, you will end up with an issue whereby a portlet edit on one node in the cluster does not appear on other cluster nodes without a server restart on the other nodes. Read the rest of this entry »

Posted in Java, Portal, WebSphere, WebSpherePortal | Tagged: , , , | 6 Comments »